^ Click For Menu

XeGaming


XeGaming 1.7.2/5

XeGaming is currently not compatible with 1.7.7

In order to connect to XeGaming you will have to downgrade your client to Minecraft version 1.7.2 or 1.7.5.

XeGaming

More News and Announcements to come!


Home - XeGaming

"A Thankful Heart Production"

© XeGaming 2014 - "Xe Theory" | Site Made by Matt Wolf

XeGaming.com

XeGaming 1.7.2/5

XeGaming is currently not compatible with 1.7.7

In order to connect to XeGaming you will have to downgrade your client to Minecraft version 1.7.2 or 1.7.5.

XeGaming

More News and Announcements to come!


Home - XeGaming

"A Thankful Heart Production"